Forcing the latest TeamSpeak client version

As of today I am forcing the update for the latest version (3.0.18.1) of the TeamSpeak client, so you have to update or you won’t be able to connect to the TeamSpeak server.
The reason for this is that in the previous version there is an exploit available which allowed people (who take advantage of this) to send files to other users on TeamSpeak without consent.

You can use the automatic updater or download the latest version of your client here

*Quote from TeamSpeak.com
TeamSpeak 3 Client 3.0.18.1 is Available

We have just released a very important security update for the TeamSpeak 3 Client addressing a RFI (Remote File Inclusion) vulnerability. Please upgrade your desktop clients to version 3.0.18.1 immediately. The update is available for Windows, Linux and OS X. Mobile clients for Android and iOS are not affected by this issue.

Posted in Uncategorized

Leave a Reply

Your email address will not be published.

TeamSpeak.com
Visitors
Flag Counter
WordPress Appliance - Powered by TurnKey Linux